3P by xguru 1달전 | favorite | 댓글 3개

- 첫번째 API 호출 전에 버전 번호와 특정 HTTP 헤더를 체크해서 에러를 발생시키도록 수정
ㅤ→ 버전 필드 없거나 6.0 이하는 에러
ㅤ→ 7.14 이상의 버전은 X-Elastic-Product HTTP 헤더가 없거나 값이 "Elasticsearch" 가 아니면 에러
ㅤ→ 7.14.0 아래 7.x 버전은 tagline 에 "You know, for Search", build_flavor 가 "default" 값이 없으면 에러

kbumsik 1달전  [-]

음 근데 이정도로는 포크들도 똑같은 헤더 구현하면 끝인 것 같은데...ES가 굳이 논란을 만들고 있네요

tkwlsrl 1달전  [-]

음.. Elasticsearch 라는 헤더를 쓰면, "상표권 위반"으로 걸 수 있지 않을까요? ㅎㅎ

xguru 1달전  [-]

OpenSearch 에서 쓰지 말라는 거네요.

- AWS, ElasticSearch와 Kibana의 포크버전 OpenSearch 공개 https://news.hada.io/topic?id=4064
- AWS가 Elasticsearch와 Kibana의 오픈소스 fork 발표 https://news.hada.io/topic?id=3620
- Elastic, AWS가 사용 못하게 라이센스 변경 https://news.hada.io/topic?id=3606
- ElasticSearch를 둘러싼 AWS와 Elastic의 대립 https://news.hada.io/topic?id=3628